The Mustang Forum for Track & Racing Enthusiasts

Taking your Mustang to an open track/HPDE event for the first time? Do you race competitively? This forum is for you! Log in to remove most ads.

  • Welcome to the Ford Mustang forum built for owners of the Mustang GT350, BOSS 302, GT500, and all other S550, S197, SN95, Fox Body and older Mustangs set up for open track days, road racing, and/or autocross. Join our forum, interact with others, share your build, and help us strengthen this community!

AC Issues, Scosche kit?

384
0
Maui
I noticed the other day when it was blistering hot that my AC wasn't really working on the driver side vents. When facing the steering wheel, the left vent and the middle left vent, seem to get only slightly cool, but the middle right vent and passenger vent all the way to the right get very cool air. I notice when I close the passenger side vents the driver side vents get cooler.. Strange, I never noticed this before I guess because it's usually in the garage so when I drive out (short distances usually) it's already cool in the car...

I did get the engine detailed and washed yesterday by a professional detailer, but I don't think that's the problem b/c thinking back my A/C never really seemed cool... I did install the scosche fd1441b double din kit in December with the touch screen temperature control so now I'm thinking that could be it? I know that kit is supposed to work with dual climate and single climate controls...maybe something wrong with that. I heard Scosche was having issues with it draining the battery on older software versions but I have the newer version and haven't read about it causing AC problems. I don't think I have a leak in my AC system.. Haven't really tracked the car (can't on Maui) and only have about 4000 miles... Anyone have any ideas? I could probably take it to the dealer if there's no simple fix. Maybe I should try putting the old stereo with the stock A/C controls in to see if that makes a difference...Any help would be appreciated.

Thanks,
Jeff
 
I'd hook up the stock a/c controller like you said, the dealer will blame the aftermarket parts anyway. It might save you the hassle.
 
384
0
Maui
YellowBoss said:
Jeff
You are low on freon gas, if it is still called that. I know it does not make sense and all should be warm but that is what the problem is.

So presumably there's a leak somewhere? Should I take it to the dealer to see if I have a leak??
 
384
0
Maui
YellowBoss said:
I can say for sure there is a leak but you have 3/36 bumper to bumper. I would bring it in.

Thanks for your help. I took it to the dealer and they took a look and said I definitely have a leak. They said i needed a new charging valve and a new condenser too...Seems a little early for the A/C system to go awry... Luckily it's all under warranty. phew....
 

TMO Supporting Vendors

Latest posts

Buy TMO Apparel

Buy TMO Apparel
Top