The Mustang Forum for Track & Racing Enthusiasts

Taking your Mustang to an open track/HPDE event for the first time? Do you race competitively? This forum is for you! Log in to remove most ads.

  • Welcome to the Ford Mustang forum built for owners of the Mustang GT350, BOSS 302, GT500, and all other S550, S197, SN95, Fox Body and older Mustangs set up for open track days, road racing, and/or autocross. Join our forum, interact with others, share your build, and help us strengthen this community!

Boss shifter problems

241
61
Okay so I'm back up at the track. With normal driving around town my car shifts fine gears 1 through 6. When I get on the track and I'm starting to run higher speeds and higher revs it will not shift into fourth or fifth. It seems to get worse as the day goes on. I don't understand it. This is absolutely the worst shifter I've ever had in my life. I think it's defective. This never happens until I'm going higher speeds at the track. I'm shifting on straightaways into these gears so the car is level and my shifts are precise and perfect. I feel that if it was the clutch it would have been in all gears not just fourth and fifth. If it's the shifter and why does it shift normal at slower speeds? Is there a problem when shifting at higher RPMs say 7500 and over. Is this something I should take back to ford? Should I put Semi solid engine and transmission mounts or a new shifter in the car? Would it be possible that the clutch doesn't have enough strength to deal with this kind of speeds? Have there been any pressure plate issues???????? HELP

Sorry about all the typos. The first post was voice dictated off my I phone which did not work too well.


Other than that this car is flat-out amazing on the track and I can't wait to be able to treat it properly with a good shifter.
 
I was reading an article with some comments from some racer, he said the issue is that the shifter is half mounted to the body and half to the tranny, so it moves around since the tranny and body are not hard mounted to each other. I've had the same kind of issues in other cars too, it feels like the alignment is off which seems to be what the actual issue is.

There are a few threads here, MGW seems to be the fix that works.

Some people have had issues with the pressure plate and it refusing to go into gear at all on the track, I don't recall the details but it is in a thread here. I don't think that is your problem though.


One question though, how are you getting it over 7500 rpm? ;D
 
7500 is max but I know I have seen mine hit 7600 before limiter kicked in.Trackey doesen't effect rev limit.
 

Justin

Save the dawn for your dishes!!!
a few days ago I took the car to 7500 in second went to shift to third and the pedal was stuck to the floor after a few seconds and the car winded down it came back up....if it keeps it up I will be at the dealer bitching everyday till they fix it. I hope this was just a fluke
 
boss2511 said:
a few days ago I took the car to 7500 in second went to shift to third and the pedal was stuck to the floor after a few seconds and the car winded down it came back up....if it keeps it up I will be at the dealer bitching everyday till they fix it. I hope this was just a fluke

It is not a fluke, report it to the dealer and make sure they contact engineering. If not call Ford yourself. This happened to me and many others, the more they know about this problem the harder they will look for a fix for all.

If it happened once it will happen again, I talk from experience.
 
Had that happen to me today while enjoying the weather. It didn't want third until it wound down a bit and went on the second try. It was like the gate was blocked by a piece of rubber, bounced right back. I guess after I change my shifter out then take it to the dealer for the fluid change I'll report it. The shifting is the only complaint I have with this car so if the get that right I'll be a happier man.
 

TMSBOSS

Spending my pension on car parts and track fees.
6,284
3,313
Exp. Type
HPDE
Exp. Level
5-10 Years
Illinois
My problems started the same way. Ran through first and second without issue. Pushed in the clutch to shift to third and it felt like the gate was blocked. Worst part about it was that I was running my brother in his M3 on a track of course, and I was beat by the M3 and my brother. :mad:

Had the TSB taken care of at my dealer, on of the good one's, and installed the MGW. World of difference. ;D
 
TMSBOSS said:
My problems started the same way. Ran through first and second without issue. Pushed in the clutch to shift to third and it felt like the gate was blocked. Worst part about it was that I was running my brother in his M3 on a track of course, and I was beat by the M3 and my brother. :mad:

Had the TSB taken care of at my dealer, on of the good one's, and installed the MGW. World of difference. ;D

I also had the same problem with the 2-3 upshift!! Did the MGW shifter cure that issue?
 
241
61
I think it may be the clutch is a big part of the issue. This clutch/trans is made for the regular mustang right? What are the rpms in a gt? 6500?
 
boss1 said:
I think it may be the clutch is a big part of the issue. This clutch/trans is made for the regular mustang right? What are the rpms in a gt? 6500?
I agree it's mostly the clutch but the Boss has an upgraded clutch from the GT.
 

TMO Supporting Vendors

Top