Clicking Noise from Passenger Front?

Discussion in 'GT350 and S550 Technical Forum' started by HR692, Nov 17, 2018.

  1. HR692

    HR692 TMO Intermediate

    Messages:
    64
    Likes Received:
    43
    Joined:
    Jan 20, 2018
    Location:
    Virginia
    Ever since I bought the car I occasionally hear a clicking sound from passenger front at parking lot speeds 1-10 mph. I usually hear it pulling into a driveway, parking lot or slowing to a stop. I assumed it was from the rotor or caliper? Anyone have experience with this? All wheels are properly torqued.
     
  2. byronj

    byronj TMO Addict

    Messages:
    1,309
    Likes Received:
    254
    Joined:
    Jul 17, 2012
    Location:
    Bay Area
    Ive heard a couple of things. One is the bearing could be going bad. Another GT350 owner had his bearing replaced and the noise was still there. The dealership swapped tires to the opposite side and the clicking magically went away. Apparently they just stood there scratching their noggins asking WTF, how did that happen? Wish I could be of more help to you
     
  3. Coz

    Coz TMO Advanced

    Messages:
    161
    Likes Received:
    95
    Joined:
    Mar 4, 2018
    Location:
    Philly Metro Area
    If you have a two-piece rotor, make sure everything is fastened on the ring to hat properly.
     
  4. Coz

    Coz TMO Advanced

    Messages:
    161
    Likes Received:
    95
    Joined:
    Mar 4, 2018
    Location:
    Philly Metro Area
    Also, make sure your center caps are properly seated. Maybe try removing and reinstalling them to seat them in a different position. Try swapping wheels and see if the noise moves with it.
     
  5. HR692

    HR692 TMO Intermediate

    Messages:
    64
    Likes Received:
    43
    Joined:
    Jan 20, 2018
    Location:
    Virginia
    I’ll give it a shot...thanks.
     

Share This Page