The Mustang Forum for Track Enthusiasts

Track Mustangs Online was built specifically for those who track their Mustangs!

Engine cutout that has gotten progressively worse - a solid mystery (gen1 coyote)

captdistraction

GrumpyRacer
1,720
1,226
Phoenix, Az
The setup:
2011 chassis racecar, new custom coyote build with about 8 hours of runtime on it.
stock fuel tanks, radium surge tank with regulator (feed connected to stock tank pump outlet, radium regulated output connected to stock hardline to rail, overflow connected to tank at filler neck connection)
AEM 50-1200 E85 pump in radium tank
Stock PCM with aftermarket tune via SCT flasher, all new harnesses, updated style VCT solenoids; cobrajet intake and monoblade throttlebody
3 year old PC680 Battery charged via boss 302 alternator kit with regulator plugged in (stock configuration driven by PCM) - kept on tender when not in use

The issue:
over time in a race, the car will bog down coming out of a corner (it seems like its mostly right hand turns), and this has gone from a light stutter, to a full second of weirdness, to a complete inability to rev/lay down power where I had to be towed in from a race. This has shown up in the last few events (first time I barely noticed it and figured I was low on fuel). The next event was sound restricted and I found the car getting worse over time, and the last race on the 5th lap (with 2 laps under caution) the car cut out coming out of a right, I also could not restart the car:

see the issue starting at the 7 minute mark - along with running data visualization.


I do measure fuel pressure, albeit at the output of the radium surge tank and not at the rail (which means I might not see a pinched line or other feed issue - as it would just dump extra pressure through the regulator on the tank).
Fuel pressure is consistent, however, as is voltage (as we considered an internal battery short that might show up under heavy G's along with why its so difficult to restart the car)

I checked grounds, wiring connections, inspected the crank trigger sensor (it was clean), completed a neutral profile reset service, and then bypassed the surge tank. I ran the next day without issue, however, I did have one little blip in practice but its hard to tell if that was related or not. Data showed nothing real interesting.


data from the fault can be seen here: https://podium.live/events/nasa-az-st2-chuckwalla-valley-raceway-2-13/device/50mustang?laps[]=4 - there's a selection for graph by time to see the data once the car came to a rest.

Here's some screen grabs of the relevant sections:
1613933816111.png

1613933824954.png

1613933834139.png

1613933862746.png

1613933881681.png

1613933895434.png

1613933913259.png

1613933924994.png

1613933937992.png

1613933948072.png

Thoughts on what this could be? Could I have missed a wrench light and limp mode? Because I don't have a PCM keepalive, I don't believe I had any saved errors/CELs to review (I need to remember in these cases to leave the car on if I can to ensure recording). My data is also limited to performance focused data, not so much engine parameters like spark advance, cam timing, etc. I can pick up something like an AIM solo DL to start monitoring operational parameters and see if that data sheds any light, but I'm baffled. The car runs now, but I don't like the idea of not knowing why this was occuring or not using the surge tank; also the risk of losing a race session due to this issue is unfortunate.

All I have for moving forward steps are:
-collect more data
-check surge tank pump (the surge tank was full of fuel upon disassembly)
-continue tracing lines, wires, grounds
 

captdistraction

GrumpyRacer
1,720
1,226
Phoenix, Az
I need to set up a testing day, its just unfortunate this occurs under max G loading as that's hard to simulate outside racing conditions. I spoke with Capaldi Racing and they felt an issue might be present in the battery and charging system, and that unplugging the alternator regulator might be a good idea (as it had been running at a constant 15v up until the issue). That said, I went back to a previous motor in 2018 and the alternator had similar behavior (constant 15v) gut feeling is this is electrical.
 

Mad Hatter

Gotta go Faster
3,374
1,874
Santiago, Chile
When we switched to a new harness a while back, we found a one of the leads to the coil had its pins incorrectly wired from the factory (Monday work after tequila Sunday?). Had to rewire it then all was well. Before that, we would get codes and power loss all the time,

We thought because its was new, it had to be Ok, Not!!

Probably a long shot but...Best of Luck!!!!
 

blacksheep-1

Epic Contributor
2,945
2,658
the banana did something like this, go to the trunk and check the connection from the harness to the fuel pumps, it was a dirty connector, cleaned it, and zip tied the connection and it solved the problem. I hope you're as lucky.
 

captdistraction

GrumpyRacer
1,720
1,226
Phoenix, Az
so far we have:
-Possible PCM fault
-Possible battery fault
-Possible Alternator overcharge/fault
-Possible Fuel pump or surge tank issue
-Possible Fuel feed / line issues
-Possible Wiring faults
-Possible throttle body (or related wiring fault)
I'm just a new chassis away from a whole new car lol

Updates so far:
-Initial testing of the battery seem ok, but it might be undersized - no detected faults/shorts
-Picked up a AIM Solo DL which can log engine parameters on track
-Moved fuel pressure sender to the rail
-Reviewed all ground points and wiring - all looks good
-Cleaned the maf and air filter (the air filter was pretty gross from all the dust we've had lately - and a couple offs)
-I have to replace the front main seal which means I'm pulling the timing covers so I'll at least get a mechanical inspection but I'm not expecting to find anything there
-oil change completed, nothing weird
Being that this is only showing up in turns (or in dips in RPM since that's also something that would happen in a turn) I'm trying to rule out much of the above but its a difficult process and I can either throw stuff (money) at the wall and see what sticks - the good news is the last race went on without issue, however the next test I want to put the car back to its base configuration to see if we can catch more data.
 

TMSBOSS

Epic Contributor
5,651
2,621
Illinois
HPDE
5-10 Years
You may be able to avoid some work by pulling the front main seal with a slide hammer. Drill or punch a small hole and screw in a sheet metal screw on the slide hammer. Pull the seal with the slide hammer. Replace the seal using a piece of pipe as a driver. May save you a hour or two.
 

captdistraction

GrumpyRacer
1,720
1,226
Phoenix, Az
You may be able to avoid some work by pulling the front main seal with a slide hammer. Drill or punch a small hole and screw in a sheet metal screw on the slide hammer. Pull the seal with the slide hammer. Replace the seal using a piece of pipe as a driver. May save you a hour or two.
I'm deeply considering that, as its probably closer to 3-4 hours savings, while it would be nice to go in and inspect everything, I don't anticipate there being anything to see as the engine has been running extremely strong.
 

JAJ

TMO Addict
888
826
In the V6L
So I went through your data online and switched on the two previous laps to make a comparison. The only signal that doesn't make sense is TPS. Coming out of the corner, the throttle doesn't open - it chatters a bit and that's all. You can see in the screen cap below - between about 0.85 and 1.1 - that the throttle goes to full on the two previous laps, but it just doesn't respond on Lap 5. The ECU has decided, for some reason, that either you're not asking for full throttle or there's something that's telling the ECU not to provide it even if you're asking for it. It could be limp mode, although without knowing anything about your tune, it's hard to say if limp mode is still possible - it may have been disabled.

1614100286409.png


It looks to me like something electrical, and its somewhere in the wiring, sensors and logic that affects the throttle. It could be pedal position sensor, it could be MAF, it could be CHT, or the ECU itself. It's very likely throwing a code in any case, you just have to find a way to capture it.
 

captdistraction

GrumpyRacer
1,720
1,226
Phoenix, Az
I sold my autoblip and removed it. I had soldered it in the harness and I was careful to make sure the harness was put back to stock, but I might go in there again and make sure nothing is going on with the TPS 1/2 signals. With the AB - when a fault occured, you'd get a wrench light, no throttle and the car would shut down (very similar); however a restart would get it running again. I think this is very similar, but ultimately different as when it runs out its stumbling where in limp mode there's a bit more regular cadence to how the engine runs (but throttle is off the table). I have some video of previous faults, I should go review those and see.

I wish I had a trace for pedal commanded (the raw pedal position) to trace against the throttle blade / TPS signal, but I also didn't see a wrench light (possible I didn't notice one). Its also both possible when it went I didn't give her the gas as I wasn't sure what was up - OR - I did give it the throttle and the trace doesn't properly reflect my foot indicating an issue at the throttle body.

I'm working on the AIM Solo DL to Racecapture integration today; hopefully I can get the commanded pedal position trace so that comparison could be built - there's always some variance from the PCM, but it should more or less follow and if I can generate a fault again maybe some more insightful data.

Finally, I printed a note to myself to not kill PCM power if it happens again so I can record any faults - I'll velcro in a handheld reader so I can quickly get that data.
 

stevbd

TMO Intermediate
48
30
Probably a stupid question but all your fuel tank vent lines are clear, not melted, etc.? They often melt on the 2011s near the exhaust.
 

TMO Supporting Vendors

Top