The Mustang Forum for Track & Racing Enthusiasts

Taking your Mustang to an open track/HPDE event for the first time? Do you race competitively? This forum is for you! Log in to remove most ads.

  • Welcome to the Ford Mustang forum built for owners of the Mustang GT350, BOSS 302, GT500, and all other S550, S197, SN95, Fox Body and older Mustangs set up for open track days, road racing, and/or autocross. Join our forum, interact with others, share your build, and help us strengthen this community!

Boss bogging and falling on its face...

unrealford

Mustang owner since 84
521
0
Just wanted to post this to see if anyone else has had this issue.

When I went to drag strip and used the standard grey key, when I launched it would take off and just die, foot to the floor and the cars fighting to get any RPMs.. Then it would slowly start taking off and the rest of the gears it was fine.

I inserted the Trackey and it never happened again, so I just continued to use Trackey.

Well, I just recently got a Steeda CAI, 93 Tune from them and it really feels a lot stronger.

I took it to track this Sunday and totally forgetting about the issues I had with it bogging when I launch, sure enough it does it over and over, I thought It was too low on gas and filled it to about 1/4 to 1/2 tank mark, still does it..

I'm about to sell the Brand new Steeda Cai/tune and return to stock and use Trackey.

Does anyone have any answers or ideas what could be happening?

Thanks Shawn..
 

unrealford

Mustang owner since 84
521
0
I'm just disabling the Traction Control..

How do I turn AdvanceTrac off, and what is it doing? Thanks I hope your onto something, when I use trackey it doesn't give issues, Does Trackey do something different?
 

ArizonaBOSS

Because racecar.
Moderator
8,552
2,392
Arizona, USA
Even with Traction Control "off" there is still stability control active and that could be causing some issues. To disable all electronic controls, hold your foot on the brake and hold down the TCS button for 5-6 seconds until you see "Advancetrac Off" on the dash. Then you are on your own.

I dunno if TK does something different with this. On the plus side, TK does have launch control.
 
Could be a bad alternator, bad fuel trims in the tune, or what happened to me with my 06, a ruptured fuel line on the hat. Or what Arizona said. If it only happens when launching at the strip Id vote for either advance track or the tune. My car did it under the slightest acceleration.
 

Justin

Save the dawn for your dishes!!!
I didnt have this issue with the silver key or the steeda tune when I ran at the track and I would run with just TSC off and advanced track on.

I would talk with shaun from AED sounds like it could be a trq managment problem. I had the steeda tunes reg idle and cam and later went to AED.....blows the steeda tunes away. off topic I know but worth mentioning.

You may want to contact steeda and try to data log whats happening and see if its something they can fix.
 

unrealford

Mustang owner since 84
521
0
If I had to take a stab in the dark I'd say clutch protection kicking in.
Makes sense the TK tune doesn't have it and the grey key does.
Excellent Shaun, thanks. I searched for that and found a few post that you discussed this with others.

I can 100% agree with this , I did smell clutch, not alot, but I did smell clutch.
From what I searched its a Trq monitor to protect the clutch.. ( I found in your other post)
 
unrealford said:
If I had to take a stab in the dark I'd say clutch protection kicking in.
Makes sense the TK tune doesn't have it and the grey key does.
Excellent Shaun, thanks. I searched for that and found a few post that you discussed this with others.

I can 100% agree with this , I did smell clutch, not alot, but I did smell clutch.
From what I searched its a Trq monitor to protect the clutch.. ( I found in your other post)

Basically yes.
Used for warranty reasons and who can blame Ford for doing this.

Very few tuners can properly remove this feature from the ECU, and those that can sometimes will not as clutch failure can happen with this removed.
 
So thats why it kept happening to me at the track too. I would have a good launch and it would just bog and then pick up speed again. It was very noticeable on video too. It was killing my 1/4 times. I couldnt figure out what it was and I had the AdvanceTrac and traction control disabled. So this happens a lot with the trq management to save the clutch?
 

unrealford

Mustang owner since 84
521
0
Boss240 said:
So thats why it kept happening to me at the track too. I would have a good launch and it would just bog and then pick up speed again. It was very noticeable on video too. It was killing my 1/4 times. I couldnt figure out what it was and I had the AdvanceTrac and traction control disabled. So this happens a lot with the trq management to save the clutch?
Do you have a link to video? I'd like to see it.
 
It plays so much better from my email. Its hard to tell after I downloaded to photobucket cuz video seems to be a poor download.
 

TMO Supporting Vendors

Top