The Mustang Forum for Track & Racing Enthusiasts

Taking your Mustang to an open track/HPDE event for the first time? Do you race competitively? This forum is for you! Log in to remove most ads.

  • Welcome to the Ford Mustang forum built for owners of the Mustang GT350, BOSS 302, GT500, and all other S550, S197, SN95, Fox Body and older Mustangs set up for open track days, road racing, and/or autocross. Join our forum, interact with others, share your build, and help us strengthen this community!

Engine Hesitation/Surge At constant throttle.

So,
Has anyone run into this issue....Under acceleration the car seems fine but at constant throttle constant speed the car feel like it’s cutting out kinda. It surges and hesitates. Has anyone had anything like that happen. I’m thinking Mass Airflow sensor due to the fact that under high air demand it seems ok but then at constant throttle it surges and hesitates. Any ideas??
 
You could try cleaning the MAF but it is pretty hard to do as the wires aren't really exposed and are in the metal housing. Do you use an oiled air filter? Also may be worth while to clean the throttle body as mine was pretty dirty the first time I cleaned it. Also, check for air leaks after the MAF.
 
You could try cleaning the MAF but it is pretty hard to do as the wires aren't really exposed and are in the metal housing. Do you use an oiled air filter? Also may be worth while to clean the throttle body as mine was pretty dirty the first time I cleaned it. Also, check for air leaks after the MAF.
Thanks for the reply! I do use an oiled filter! So, I’ll check the throttle body and check for leaks as well. I’m going to try to get at the MAF. For whatever reason, I think it’s something in the intake system. Hopefully, it’s one of those 3 items.
 
Thanks for the reply! I do use an oiled filter! So, I’ll check the throttle body and check for leaks as well. I’m going to try to get at the MAF. For whatever reason, I think it’s something in the intake system. Hopefully, it’s one of those 3 items.

dont use an oiled filter.
 
So, should this symptom ever crop up for anyone else...turns out there is a TSB for this exact issue. The cause of the issue was, the nut on the output shaft from the transmission had loosened and it also finally inop-ed the cruise control. Who knew! Luckily the very sharp technician knew of the TSB.
 
28
19
Exp. Type
HPDE
Exp. Level
5-10 Years
Could you share the TSB #, I'm experiencing the same hesitation. Cleaned the MAF which helped a bit.
 
2
0
Exp. Type
Time Attack
Exp. Level
3-5 Years
Toronto
Could you share the TSB #, I'm experiencing the same hesitation. Cleaned the MAF which helped a bit.
Did the TSB solve your issue. I did the TSB last season and now I get the same issue. They redid the TSB but they are unable to resolve the issue. They had my car for 10 says.
 
2
0
Exp. Type
Time Attack
Exp. Level
3-5 Years
Toronto
So, should this symptom ever crop up for anyone else...turns out there is a TSB for this exact issue. The cause of the issue was, the nut on the output shaft from the transmission had loosened and it also finally inop-ed the cruise control. Who knew! Luckily the very sharp technician knew of the TSB.
Did the TSB solve your issue. I did the TSB last season and now I get the same issue. They redid the TSB but they are unable to resolve the issue. They had my car for 10 says.
 
Read this post with interest. I had a six month long nightmare with my 2016 GT350, surging/cutting out at constant (low) RPM.
Lemon-Lawed the car back to Ford. It ended up being a heat damaged sensor near the trans on the underside of the car, (forgot the name of it) discovered finally by visual inspection after getting TPS/Throttle body, MAF, spark plugs, wiring harness, new Platinum-tipped coils, several other sensors, etc. replaced..16 trips to two Ford dealerships over six months- bummer! Other posts mention the car's weak point being the wiring/electrical issues, blah blah, blah: I bought a 2018 @ 5k below sticker before I even gave the '16 back to Ford- Love the car, and no electrical/sensor problems with this one, but I'll ditch it when 3-year warranty is up. Only original owner gets lemon law protection, which I learned was key...
 
Hello, I am having this issue on my 2017 GT, not a 350 or anything, but my car keeps surging or acting like it loses power when constant throttle... Currently at the tuning shop to figure out the problem, my Air/fuel ratio & MAF are all over the place whenever it happens. It'll spike from normal around 13.8-14.6 or so up to 15-20 and then back to normal and so on.. My cruise control is fine, however I sent this to the shop to see if this fixes it, any advise anyone else had would be appreciative!! Also, car is automatic. Don't know if that affects anything.. I just want it to be fixed so I can finally drive again -.- put about 100 miles on the last 3 months and its supposed to be my daily..
 
28
19
Exp. Type
HPDE
Exp. Level
5-10 Years
The TSB 19-2135 didn't fix my problem. The Shelby spent more time at the shop than on the road this summer. Similar to @VUDU V8 Steve a lot of the sensors, spark plugs, MAF, throttle body, etc have been replaced. It's back in the shop now due to reverse, 3rd and 4th gears in the transmission stopped working. I'll have the check all the sensors near the transmission to see if any of those are having problems.
 

TMO Supporting Vendors

Latest posts

Buy TMO Apparel

Buy TMO Apparel
Top