The Mustang Forum for Track & Racing Enthusiasts

Taking your Mustang to an open track/HPDE event for the first time? Do you race competitively? This forum is for you! Log in to remove most ads.

  • Welcome to the Ford Mustang forum built for owners of the Mustang GT350, BOSS 302, GT500, and all other S550, S197, SN95, Fox Body and older Mustangs set up for open track days, road racing, and/or autocross. Join our forum, interact with others, share your build, and help us strengthen this community!

Boss at Texas World Speedway, 1st time out

First time out in the boss (2013), bone stock except for brake fluid. I wasn't used to the rear end skipping over bumps under power, never driven a car with a solid rear, that feeling was kind of strange, couldn't absorb up the bumps like an indy rear suspension. Coolant never got hot, but oil got to almost the yellow mark on the stock gauge, temp was 95. Need another oil cooler for hot weather.

Was about 9 seconds off my M3 pace, but that car is not stock.

One Session

[youtube]http://youtu.be/DLdmSDFGkNY[/youtube]

Another short session after a car went off track.

[youtube]http://youtu.be/r9GZLRrB8rY[/youtube]
 
JTRATX said:
5 on front and rear.

I would try to lower your rear shock setting a number or 2. I usually run my rear shocks at 3 although most run higher. TWS is a fairly rough track so soft up the rear a little and it would have soaked up the bumps a little better. I was just there in April and didn't have any problems.

Just give it a try!
 

TMO Supporting Vendors

Top