The Mustang Forum for Track & Racing Enthusiasts

Taking your Mustang to an open track/HPDE event for the first time? Do you race competitively? This forum is for you! Log in to remove most ads.

  • Welcome to the Ford Mustang forum built for owners of the Mustang GT350, BOSS 302, GT500, and all other S550, S197, SN95, Fox Body and older Mustangs set up for open track days, road racing, and/or autocross. Join our forum, interact with others, share your build, and help us strengthen this community!

High Speed Cornering issue

Sesshomurai

Hey gang,
I resolved my previous high speed braking issue with the rear end with the rear LCA's and relo brackets.
Also, adj front/rear sway bars help a lot. Car is getting more and more stable at high speeds (race worthy).

But a really weird and slightly disturbing thing happened at VIR today (most of the day was rained out for me).

Twice when making a high speed slight cornering maneuver I felt the car "brake itself" slightly (track was dry at this point).
I kid you not.
It wasn't a rub because A) No rubbing on tight cornering B) The high speed slight turn was during acceleration

I jacked the car and checked for rubbing. Didn't notice anything unusual.

I've had the Steeda CAI+Tune since Summit last weekend (where I didn't notice this), but since then I added:

- Rear LCA's,relo brackets
- 275/35/19 Hankook RS3's all around. 19x9.5 rims
- Eibach adj front/rear sway bars
- An updated to the original Steeda tune I flashed

Could the tune be interfering with the ECU and causing some kind of weird ABS intrusion? Seems impossible that would happen.
But what I experienced felt a lot like a brake engagement even though I was open or steady throttle.

Any ideas what might be happening here? Oversteer issues with the bigger/grippier front tires?

D
 

Sesshomurai

Yeah, traction control was off, but I only pushed the button. I didn't disable it completely. Maybe I need to do that?
 
darreng505 said:
Yeah, traction control was off, but I only pushed the button. I didn't disable it completely. Maybe I need to do that?
this. If it still happens with it completely turned off then you have a problem.
 
1,437
352
I've had the same thing happen on TURN 1 at Laguna Seca, the little kink in the straight as you go over the rise. Not fun. I've also had it happen on a long sweeping freeway ramp.
 

pufferfish

Supporting Vendor
1,094
66
Maryland
I have experienced the off-off intervention a few times, as I generally power rotate the car around the tight turns...cuz the slip angle is tiny. The drift crowd have it the worst with yaw and wheel slip pegging the poor TCS's brain. They pull the fuse. I wont give up ABS yet, so i deal with it. On the plus side, I found that if I do the same thing lap after lap, it seems to learn to back off. Not sure if that last bit is real or in my head though;)
 

Sesshomurai

Fat Boss said:
I've had the same thing happen on TURN 1 at Laguna Seca, the little kink in the straight as you go over the rise. Not fun. I've also had it happen on a long sweeping freeway ramp.

Oh good. It's not just me. And when you completely disabled TC, this problem went away?

Odd thing for me is that it didn't happen at previous VIR track days. Just lately, after a slew of mods.

How do I completely turn off the TC system, permanently? Hold it down for 10 seconds or something like that?
 
1,255
2
GA
darreng505 said:
Odd thing for me is that it didn't happen at previous VIR track days. Just lately, after a slew of mods.

The colder weather could have decreased your tire traction and caused the TC to compensate. I know when I ran in Road Atlanta in February it felt like I stepped on a banana peel in the brake zone.
 
At Sears Point, in turn 4, 7, 10 I was getting what felt like ABS kicking when I turned in. This was with or without trail braking and with it off/off (it did it in Sport too, turned it off to test off/off). My rear rotors heat checked pretty noticeably, and again it did this even when I was not applying the brakes. I'm pretty sure it was the advancetrac doing it, though it shouldn't in off/off. But that was the day they made us do side-by-side runs and I had so many marbles the brakes were going into ABS just braking normally on the way home. So maybe that was what confused the computer.
 
1,437
352
darreng505 said:
Fat Boss said:
I've had the same thing happen on TURN 1 at Laguna Seca, the little kink in the straight as you go over the rise. Not fun. I've also had it happen on a long sweeping freeway ramp.

Oh good. It's not just me. And when you completely disabled TC, this problem went away?

Odd thing for me is that it didn't happen at previous VIR track days. Just lately, after a slew of mods.

How do I completely turn off the TC system, permanently? Hold it down for 10 seconds or something like that?

Yes the problem went away with the Stability Control off. Turn it off by pushing in the clutch and brake and the button for about five seconds. The message will flash on the screen. My friend Marty was about to return his car about 30 seconds after buying his '11 GT500 performance pkg. He tried to do a doughnut and it wouldn't. He was freaking out until they showed him how to disable!
 

PeteInCT

#LS-378 - So many Porsche's, so little time....
Moderator
2,848
14
Connecticut
You just need the brake and the button depressed. Hit the brake first, then button, wait till the "Advanced Track OFF" message comes up. Once you shut the car down you'll need to do it again, it does not keep this setting when ignition is turned off.
 

pufferfish

Supporting Vendor
1,094
66
Maryland
has anyone installed one yet? a bit of internet research indicates they will only fit the GT500 ABS units, which is apparently what ford used for the 302S+R cars. maybe i need to give the ford tech line a call.
 

TMO Supporting Vendors

Buy TMO Apparel

Buy TMO Apparel
Top