The Mustang Forum for Track & Racing Enthusiasts

Taking your Mustang to an open track/HPDE event for the first time? Do you race competitively? This forum is for you! Log in to remove most ads.

  • Welcome to the Ford Mustang forum built for owners of the Mustang GT350, BOSS 302, GT500, and all other S550, S197, SN95, Fox Body and older Mustangs set up for open track days, road racing, and/or autocross. Join our forum, interact with others, share your build, and help us strengthen this community!

Installed Rear Seat Delete kit, now rear seat belt malfunction light comes on.

Bill Pemberton

0ld Ford Automotive Racing Terror
6,656
5,643
Exp. Type
Time Attack
Exp. Level
20+ Years
Blair, Nebraska
We kind of suspected this since there was nothing in the Ford Performance Kit to block or plug into the sensors once we unhooked the lower seat belts. Since this is a factory option in many of the cars we figured the issue might have a quick fix, so figured we would ask here as someone has likely already experienced this same situation. Hoping there is a quick fix though I also imagine it may be something we have to take into a Ford Dealership to reprogram, but pretty easy to just ask the TMO faithful. Thanks.

PS - this was in a S550 platform ( 21 Mach 1 ).
 

Bill Pemberton

0ld Ford Automotive Racing Terror
6,656
5,643
Exp. Type
Time Attack
Exp. Level
20+ Years
Blair, Nebraska
Thanks, hopefully it is something with programming, but interesting no issues on a 16. I imagined someone had done it with a GT350 or Mach 1, as I know some folks with a non R wanted to reduce weight and removed the rear seats. Had not heard of any issues but assumed I was not the first to have a malfunction code pop up.
 

Bill Pemberton

0ld Ford Automotive Racing Terror
6,656
5,643
Exp. Type
Time Attack
Exp. Level
20+ Years
Blair, Nebraska
Apparently this is an issue if someone is in the rear seat and then gets out , it can pop on the rear seat belt light as there are no sensors back there, it only recognizes the belt being attached. Hoping since this issue popped in 2021 someone has found a cure for this situation? Hoping there is a program fix because a rear seat delete option is available for the Mach 1 from the factory.
 
74
188
Exp. Type
HPDE
Exp. Level
20+ Years
Auckland, New Zealand
Could you retain the seatbelt stalk with the wires connected and plug in some donor seatbelt clips? Then wrap them up and hide under the rear seat delete? That way the car thinks the rear seat belts are in use.

Otherwise possibly something like the IPC As Built coding would need to be changed to monitor the front seats only. That might be possible with FORscan.
 

TMSBOSS

Spending my pension on car parts and track fees.
6,777
3,996
Exp. Type
HPDE
Exp. Level
5-10 Years
Illinois
Bill. Can you take the parts removed and see what changes at the connector when you fasten and unfasten the belt? Put an ohm meter on the connector pins and see what happens. If there is a change something like a dead short to open when you fasten or unfasten you will know what needs to be present to indicate “Fastened” to the system. If there is a measurable resistance, put a resistor of similar impedance in the circuit. Lots of fun, I know but a possible solution.
 

Bill Pemberton

0ld Ford Automotive Racing Terror
6,656
5,643
Exp. Type
Time Attack
Exp. Level
20+ Years
Blair, Nebraska
k_z has part of the answer as it definitely has an electrical connection and since my back doesn't bend like TMS suggests I won't likely try that at present. It appears in researching that this problem popped up with newer cars with folks sitting in the back and then getting out and then the light showing a malfunction would pop up - since the belt was no longer buckled. I figure, since I need to take it into the shop next week we can find if there is a program change or a part to fool the system, Of course just hitting the "ok" button turns of the malfunction light until the next start up , but hoping to get it permanently deleted. TMS has the right idea, but got a message earlier that that did not work , though I am not completely sure it does. With all the issues starting in 2019 to 2021 with the belt and the light I am somewhat hoping for a TSB on the situation. There has to a simple answer since rear seat deletes on GT 500s and GT350s are not experiencing this. Just figured someone had already been through this. This simple answer is just to hit the "ok " button each time you get in the car, but that is annoying and not a real fix.
Could also do what Felix suggested as I thought of that , but since getting weight out of the car is the big key, and every little bit helps, I discounted it as I need more weight out to be somewhat competitive.

Speaking of that I have not been able to get a firm answer from any Parts sources if the aluminum one piece driveshaft for a Mach 1 has a different part number. Some say it fits for sure, others say they don't know , and after a week I still have not gotten an answer from the " Driveshaft Shop." MT-82 and Tremec 3160 , one wonders if the same length and bolt up is exact and when many have no idea and others state ( by computer generation ) a unit doesn't fit, I am skeptical about ordering one only to find it is too short? Trying to get her down to 3884 with me in the car and some fuel.
 
Last edited:

TMSBOSS

Spending my pension on car parts and track fees.
6,777
3,996
Exp. Type
HPDE
Exp. Level
5-10 Years
Illinois
Bill
You may be able to check the parts already removed. No bending over, unless you drop the parts. 😳 :biggrin:
Take the buckle receiver and look for changes across the pins in that connector when buckling and un-buckling.

I am with you regarding getting in the former back seat area. I have to convince myself that cleaning the back window is a good idea. What's that line from the movie, "What's behind you is not important" Why not just sell the car and get a new one with a clean back window. Much easier. Or pay the neighbor kid to clean the windows. LOL. I am NOT going in the back seat in a Mustang with a bar. Ain't happening.

BTW, beside an annoying light, what does the lack of proper input from the seat belt sensor affect?
 

Bill Pemberton

0ld Ford Automotive Racing Terror
6,656
5,643
Exp. Type
Time Attack
Exp. Level
20+ Years
Blair, Nebraska
TMS, you are right, just an annoying light and everything you and others posted seems to be the way to go. I called Lethal Performance and after the Rep I chatted with checked he said it was a very new problem, basically just the 2021s ( though probably 22s will also have the issue ). He said one customer took the two thin wires ,checked the ohms and put in a resistor for each side. I had been told by another source that this would not work ,but it will be worth a try once my son can pop over and yank the seat delete up. See, TMS, no bending for me but my son is better than the kid who occasionally mows the yard ( actually that is the lady teacher next door with a 900 ft.wide rider that loves to do everyone's yard, ha ). Will check it out next time I get over and we can use the old clips to check stuff. Thanks everyone, was hoping someone had actually run into the problem, but sounds like it may be a somewhat easy fix?
 

Bill Pemberton

0ld Ford Automotive Racing Terror
6,656
5,643
Exp. Type
Time Attack
Exp. Level
20+ Years
Blair, Nebraska
Checked with Lethal Performance ( they had the only rear seat delete kits in the US at the time ) and they told me they had only seen one issue like mine as it was a very new problem and as far as they could tell it might have started with the 2021s - they only knew of one issue. They said the buyer with the problem checked the ohms after reinserting the buckle and then got two resistors which seemed to work. I hope so, as I was told this would not work by another individual in the know ---- will post when I get it handled. This may be a week or more since I will need to get my son to help ---- I might get stuck in that back area and never be able to get out, ha.

Geez, just noticed I am repeating myself --------Senior moment early Friday morning, already!!!
 
Last edited:

Bill Pemberton

0ld Ford Automotive Racing Terror
6,656
5,643
Exp. Type
Time Attack
Exp. Level
20+ Years
Blair, Nebraska
Thanks , had found this earlier and finally decided to just live with it, as imagine a fix will come out in the future since it is a factory option and a similar problem is occurring with the Mach E. Thanks for the link and everyone's help and thoughts.
 

TMO Supporting Vendors

Latest posts

Buy TMO Apparel

Buy TMO Apparel
Top