how do i install the race abs module?

Discussion in 'Brakes, Wheels and Tires' started by Sesshomurai, Mar 2, 2013.

  1. cloud9

    cloud9 Gary

    Messages:
    6,581
    Likes Received:
    7
    Joined:
    Nov 29, 2010
    Location:
    Sioux Falls, SD
    They flash? :eek:. I just assumed they stayed illuminated constantly. Not sure I want to deal with a flashing light....
     
  2. 06mach1

    06mach1 TMO Addict

    Messages:
    942
    Likes Received:
    88
    Joined:
    Jul 27, 2011
    Location:
    Bliss, NY
    Nothing a little black tape won't take care of! ;D
     
  3. Centri5.0

    Centri5.0 TMO Intermediate

    Messages:
    66
    Likes Received:
    0
    Joined:
    Mar 9, 2014
    Tape mod completed! Off to the races.

    Sent from my DROID4 using Tapatalk
     
  4. Black Boss

    Black Boss TMO Addict

    Messages:
    1,614
    Likes Received:
    1,107
    Joined:
    Sep 29, 2012
    Location:
    Michigan
    When I tested the new ABS module the lights stayed illuminated -- no flashing.
     
  5. Roadhouse

    Roadhouse Logan

    Messages:
    1,281
    Likes Received:
    1
    Joined:
    Jan 8, 2013
    Location:
    Tulsa, OK
    Function > Form 8)

    Hoping this works out for you on track.
     
  6. steveespo

    steveespo Lord knows I'm a Voodoo Child Moderator

    Messages:
    3,381
    Likes Received:
    607
    Joined:
    Mar 6, 2011
    Location:
    NY Metro
    Will be installing this weekend, finally got some clean roads. Out to the driveway to change Steeda x11 ball joints to prepare for the season.
    Steve
     
  7. cloud9

    cloud9 Gary

    Messages:
    6,581
    Likes Received:
    7
    Joined:
    Nov 29, 2010
    Location:
    Sioux Falls, SD
    Good deal looking forward to your report. Will be interesting to see if your lights flash or are static like Black Boss. I plan to install mine next week after we get back from hammering on these C7s.
     
  8. steveespo

    steveespo Lord knows I'm a Voodoo Child Moderator

    Messages:
    3,381
    Likes Received:
    607
    Joined:
    Mar 6, 2011
    Location:
    NY Metro
    Installed this morning here is a pic of what stays on after you run it in.
    [​IMG]

    Had a short drive to get a feel and here is my observations base on 2011 GT with 15"/13" Gt 500 brembos, Michelin PSS tires on Laguna Seca wheels, P springs and Koni Yellow on 60% firm, 40 degree air temp, Ford Racing steering rack and no Coffee ;D

    First thing is the reset clears the check brake system warning, but it came back on with a chime about 20 minutes into the drive, no big deal but annoying. Second the steering is very different, there is hardly any assist, just enough and no play around center, I am guessing the Advance Track is Really OFF and there are no signals to the rack except what the shaft is doing. The drive was uneventful, I got the engine, brakes and tires up to temp (street driving) and did a few panic stops from 40, initial impression is the ABS comes on 'softer' less pedal thumping and vibration than before. I did about 5 of these, increasing the pedal pressure and sharpness each time and it stayed the same. The true test will come on track, will post further impressions then.

    Lastly, if you install this and the TC icons are flashing or the ABS icon is on I would be concerned, there might be something wrong with the module or a connection to the harness.
    Steve
    PS Tire pressure light is on because I don't use sensors anymore.
     
  9. cloud9

    cloud9 Gary

    Messages:
    6,581
    Likes Received:
    7
    Joined:
    Nov 29, 2010
    Location:
    Sioux Falls, SD
    Thanks for posting Steve. That all sounds good other than the chime. That will be a little annoying during a track session. Now go get some coffee :)
     
  10. Black Boss

    Black Boss TMO Addict

    Messages:
    1,614
    Likes Received:
    1,107
    Joined:
    Sep 29, 2012
    Location:
    Michigan
    Thanks Steve. Yes, The warnings are consistent with what I experienced, although I didn't run for 20 mins, and get the annoying chime :(. My Track event for next Friday just got cancelled so it will be 2 weeks before I can test at the track.
     
  11. Centri5.0

    Centri5.0 TMO Intermediate

    Messages:
    66
    Likes Received:
    0
    Joined:
    Mar 9, 2014
    Yes sounds like I will need to have the initialization sequence completed.

    Sent from my DROID4 using Tapatalk
     
  12. Black Boss

    Black Boss TMO Addict

    Messages:
    1,614
    Likes Received:
    1,107
    Joined:
    Sep 29, 2012
    Location:
    Michigan
    Just went out for a longer test drive. Same lights as Steve, however Chime comes on every 10 minutes, and message requires reset -- this will be annoying on the Track :(

    Advanced Track is Off -- Was easily able to lose the rear on cold PSS street tires. ABS brake modulation feels more rapid than Stock ABS.
     
  13. cloud9

    cloud9 Gary

    Messages:
    6,581
    Likes Received:
    7
    Joined:
    Nov 29, 2010
    Location:
    Sioux Falls, SD
    Oh man that chime is going to be annoying........
     
  14. steveespo

    steveespo Lord knows I'm a Voodoo Child Moderator

    Messages:
    3,381
    Likes Received:
    607
    Joined:
    Mar 6, 2011
    Location:
    NY Metro
    It's it's own special chime too. We need to check with Bill at rehagen and Mark Wilson if he's still at Ford Racing and find out if there is a way to disable it. Probably possible through the Ford IDS software.
    Steve
     
  15. Centri5.0

    Centri5.0 TMO Intermediate

    Messages:
    66
    Likes Received:
    0
    Joined:
    Mar 9, 2014
    Was not able to complete initialization sequence with ids software at dealer. However ABS is working flawlessly and TC and advancetrac is off. So.. ran at TWS this past weekend with zero braking issues. Have the c module

    Sent from my DROID4 using Tapatalk
     
  16. Budget Boss

    Budget Boss TMO Advanced

    Messages:
    185
    Likes Received:
    14
    Joined:
    Jan 29, 2014
    Location:
    Van Alstyne, TX
    I gave my M-2353-CA to Terry Fair to test and he likes it so much he going to buy it from me. This past weekend at TWS I had terrible problems with the Advancetrac coming back on. Actually, it was scary when it came back on as it took control of the car and I was unable to do anything to recover. I ended up in a ditch in front of corner 4 flag station and had to be towed back. The first thing I did when I got home was order another M-2353-CA.
     
  17. steveespo

    steveespo Lord knows I'm a Voodoo Child Moderator

    Messages:
    3,381
    Likes Received:
    607
    Joined:
    Mar 6, 2011
    Location:
    NY Metro
    C module is what Gary and I ran into problems with last fall. Would not sync up and the Advance Track icons kept flashing. We thought the -CA module was the answer but although it integrates fine it gives all kinds of brake system warnings. Will live with it though if it performs well on track.
    Steve
     
  18. Centri5.0

    Centri5.0 TMO Intermediate

    Messages:
    66
    Likes Received:
    0
    Joined:
    Mar 9, 2014
    Ouch, which group were you running in? I was in the black gt #71 in group 3. My abs is still flashing, as initialization is incomplete, but it worked flawlessly. TC and ESP remained off. Car ran well, driver not so good. ABS module was a win though.

    Sent from my DROID4 using Tapatalk
     
  19. Centri5.0

    Centri5.0 TMO Intermediate

    Messages:
    66
    Likes Received:
    0
    Joined:
    Mar 9, 2014
    My thoughts exactly, it works well. I have functioning abs and TC and advancetrac do not come back on, no matter my yaw rate or slip angle. Which is exactly what I was shooting for.

    Sent from my DROID4 using Tapatalk
     
  20. Budget Boss

    Budget Boss TMO Advanced

    Messages:
    185
    Likes Received:
    14
    Joined:
    Jan 29, 2014
    Location:
    Van Alstyne, TX
    I was in HPDE 2. Spun out in turn 4, which shouldn't of happened. I did 3 laps at 5/10th and then 2 laps at 8/10ths, then on the 6 lap I was still about 8/10ths when I spun out. It sucked. The one good thing is I had an instructor, Marty, when it happened and he made sure to tell them it wasn't driver error, but car error.
     
    Dark Horse likes this.

Share This Page